MB Star C3 09/2015 Xentry cannot work on W204?

MB Star C3 Star diagnostic system failed to work on Mercedes W204? Here is the customer solution. You are at your risk!

 

Problem:

I have DELL D630 with Xentry 09/2015 and MB Star C3 multiplexer. I have connected many cars (W202, W203, W210, W211, W245, etc) and there is no problem with connection – everything is working like a charm. Some days ago, I have bought W204 C280 from 2007. After I choose model, engine and transmission, and I go to diagnostic I see this:

“The diagnosis application is being started…”

mb-star-c3-w204-1

and few seconds later this:

“Initialization of the multiplexer has failed”

mb-star-c3-w204-2

My Mux is not compatible with W204? I searched few hours without success.

 

Customer solution:
W204 and X204 is the last Mercedes models which working without some special modifications.
You can try:

First try in toolkit.ini delete line skipcomports=all and set line usecomport=2 then you will see in SDconnect toolkit PartD on display after mux connection.

First save your original file for sure.

Try look into C:\Userdata\Config\Xentry\driver – slave.ini and set there com port which you have used for PartD.

 

Report:

There was no change because I didn’t restarted system. After restart work perfect.

Your solution work perfectly! Probem solved. Everything is working like a charm.

 

Mbstartool.com solution:

If you need to deal with newer Mercedes models, better go for SD Connect C4 or Xentry C5 diagnostic system.